SAM - Software Asset Connections Jobs started failingIssue <!-- /*NS Branding Styles*/ --> .ns-kb-css-body-editor-container { p { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } span { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } h2 { font-size: 24pt; font-family: Lato; color: var(--now-color--text-primary, black); } h3 { font-size: 18pt; font-family: Lato; color: var(--now-color--text-primary, black); } h4 { font-size: 14pt; font-family: Lato; color: var(--now-color--text-primary, black); } a { font-size: 12pt; font-family: Lato; color: var(--now-color--link-primary, #00718F); } a:hover { font-size: 12pt; color: var(--now-color--link-primary, #024F69); } a:target { font-size: 12pt; color: var(--now-color--link-primary, #032D42); } a:visited { font-size: 12pt; color: var(--now-color--link-primary, #00718f); } ul { font-size: 12pt; font-family: Lato; } li { font-size: 12pt; font-family: Lato; } img { display: ; max-width: ; width: ; height: ; } } SAM - Software Asset Connections job suddenly started failing in production without any errors. Could you please look into it? Release<!-- /*NS Branding Styles*/ --> .ns-kb-css-body-editor-container { p { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } span { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } h2 { font-size: 24pt; font-family: Lato; color: var(--now-color--text-primary, black); } h3 { font-size: 18pt; font-family: Lato; color: var(--now-color--text-primary, black); } h4 { font-size: 14pt; font-family: Lato; color: var(--now-color--text-primary, black); } a { font-size: 12pt; font-family: Lato; color: var(--now-color--link-primary, #00718F); } a:hover { font-size: 12pt; color: var(--now-color--link-primary, #024F69); } a:target { font-size: 12pt; color: var(--now-color--link-primary, #032D42); } a:visited { font-size: 12pt; color: var(--now-color--link-primary, #00718f); } ul { font-size: 12pt; font-family: Lato; } li { font-size: 12pt; font-family: Lato; } img { display: ; max-width: ; width: ; height: ; } } Zurich or newer release Cause<!-- /*NS Branding Styles*/ --> .ns-kb-css-body-editor-container { p { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } span { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } h2 { font-size: 24pt; font-family: Lato; color: var(--now-color--text-primary, black); } h3 { font-size: 18pt; font-family: Lato; color: var(--now-color--text-primary, black); } h4 { font-size: 14pt; font-family: Lato; color: var(--now-color--text-primary, black); } a { font-size: 12pt; font-family: Lato; color: var(--now-color--link-primary, #00718F); } a:hover { font-size: 12pt; color: var(--now-color--link-primary, #024F69); } a:target { font-size: 12pt; color: var(--now-color--link-primary, #032D42); } a:visited { font-size: 12pt; color: var(--now-color--link-primary, #00718f); } ul { font-size: 12pt; font-family: Lato; } li { font-size: 12pt; font-family: Lato; } img { display: ; max-width: ; width: ; height: ; } } If you check the node logs for the job run, we should see an error message like the one below. "lastGlideError": "Operation against file 'cmdb_ci_db_mysql_instance' was aborted by Business Rule 'Duplicate Name Prevention CMDB^3fe6be31e4cab290a404cddd44126e80'. Business Rule Stack: Duplicate Name Prevention CMDB", Full error *** ERROR *** *** Script: SAMPDataSourceIntegrationUtils: [2026-04-29T07:00:34.022Z]: {"message": "Failure to update table","table": "cmdb_ci_db_mysql_instance","lastGlideError": "Operation against file 'cmdb_ci_db_mysql_instance' was aborted by Business Rule 'Duplicate Name Prevention CMDB^3fe6be31e4cab290a404cddd44126e80'. Business Rule Stack:Duplicate Name Prevention CMDB","changes": {"software_install": "0844e0182b644f547b52fb05ce91bf1b"}}-------- STACK TRACE ---------at [global] 'GlideQueryEvaluator' [sys_script_include:d52b3c8a08013300fa9b4300d8d67a76]:479 (reportFailure)at [global] 'GlideQueryEvaluator' [sys_script_include:d52b3c8a08013300fa9b4300d8d67a76]:464 (update)at [global] 'GlideQuery' [sys_script_include:864c9ebf73631300bb513198caf6a721]:368 (update)at [global] 'SAMPDataSourceIntegrationUtils' [sys_script_include:8a6eebc4e75300107aea07d8d2f6a917]:95at [global] 'AssetManagementPerGlideRecordBaseJob' [sys_script_include:054adaa873c3330012a9e5e7caf6a79a]:55at [global] 'AssetManagementBaseJob' [sys_script_include:54573868538313009961ddeeff7b1296]:623at [global] 'AssetManagementBaseJob' [sys_script_include:54573868538313009961ddeeff7b1296]:79at [global] 'SAM - Software Asset Connections' [sysauto_script:c39f2d4c7fc700107aea7500fee86bd3]:23at [global] 'Stream' [sys_script_include:9f50ba7773a31300bb513198caf6a791]:375 (forEach)at [global] 'SAM - Software Asset Connections' [sysauto_script:c39f2d4c7fc700107aea7500fee86bd3]:20 (createSoftwareInstalls)at [global] 'SAM - Software Asset Connections' [sysauto_script:c39f2d4c7fc700107aea7500fee86bd3]:31 Resolution<!-- /*NS Branding Styles*/ --> .ns-kb-css-body-editor-container { p { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } span { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } h2 { font-size: 24pt; font-family: Lato; color: var(--now-color--text-primary, black); } h3 { font-size: 18pt; font-family: Lato; color: var(--now-color--text-primary, black); } h4 { font-size: 14pt; font-family: Lato; color: var(--now-color--text-primary, black); } a { font-size: 12pt; font-family: Lato; color: var(--now-color--link-primary, #00718F); } a:hover { font-size: 12pt; color: var(--now-color--link-primary, #024F69); } a:target { font-size: 12pt; color: var(--now-color--link-primary, #032D42); } a:visited { font-size: 12pt; color: var(--now-color--link-primary, #00718f); } ul { font-size: 12pt; font-family: Lato; } li { font-size: 12pt; font-family: Lato; } img { display: ; max-width: ; width: ; height: ; } } * It is important to update the business rule so that it does not conflict with the SAM job. * The "failure to update table" error is caused by the custom business rule "Duplicate Name Prevention CMDB" in this situation. Typically, you should check the node logs to find the specific error in each scenario and take appropriate action to resolve it.