Submit button / Order now button is not visible in Service Portal for some users


Description

Submit button / Order now button on catalog items is missing in Service Portal for some users.

Cause

The user has snc_read_only role added. The OOTB catalog item widget shows the submit/order now button only to the users who do not have the snc_read_only role.

The below Line in the server-script of the widget (ID: widget-sc-cat-item-v2) does the role check.

data.can_create_cart_item = canCreateCartItem(className) && !gs.hasRole('snc_read_only');

Resolution

Remove snc_read_only role from the user profile.

Additional Information

Read-only role