Service Graph Connector for SolarWinds error 'Error: Not using a supported SolarWinds version' encountered


Description

Supported versions in the platform are SolarWinds Orion 2019.4 HF6 or 2020.2.1. HF2

Supported ServiceNow versions:
Starting with Orlando Patch 7.
Starting with Paris Patch 1.
Starting with Quebec.

SolarWinds is backwards compatible so any new versions should work.

Cause

In the guided setup the user should accept they are on a version of SolarWinds that is recent.

User should accept those conditions while in the Service Graph Connector for SolarWinds scope

Resolution



There is a step in the guided setup where the user has to accept they are on a version of SolarWinds that is recent.

If they don't accept those conditions it will throw the below error:

Flow Designer: Operation(SG-SolarWinds Hardware REST.8de959bf1bbaf4548f1665fc2d4bcbdd) failed with error: com.snc.process_flow.exception.OpException: Error: Not using a supported SolarWinds version. Confirm version in guided setup.

Note that changes will not apply if user accepted the conditions in another scope.

Additional Information

https://docs.servicenow.com/bundle/rome-servicenow-platform/page/product/configuration-management/concept/cmdb-integration-solarwinds.html