How to address error "Invalid Mapping Data" with mappings deleted messages during reviewing and completing any OOB transform map in IntegrationHub ETL


Description

When trying to review and complete any OOB transform map in IntegrationHub ETL, you will see error "Invalid Mapping Data" with message like "One of more RTE mappings have been automatically deleted due to..." please see

 



 

Release or Environment

All releases. 

Cause

This should not have any impact on conventional imports and robust transforms. The message that shows is expected.
This SCCM integration is build before IHETL was available and so there might be some invalid mappings that were accidentally created. They don’t have any affect, its just ETL cleaning up unused RTE metadata.

 

 

Resolution

This is expected message and the error is showing the reason (IRE rule missing for the mentioned look up item). The message/error can be ignored due to no impact. 


Additional Information

Similar question here

https://community.servicenow.com/community?id=community_question&sys_id=ecd865ac1bfe7450ada243f6fe4bcbf9

This may help with more info:

https://docs.servicenow.com/bundle/rome-servicenow-platform/page/product/configuration-management/concept/create-etl-transform-map.html#create-etl-transform-map


https://docs.servicenow.com/bundle/rome-servicenow-platform/page/product/configuration-management/task/t_CreateCIIdentificationRule.html