Cannot Open any record in Classic Mobile app


Description

In the Classic Mobile app or $m.do, try to access any record. The page redirects to the previous page.

The console error message is shown:

"java.lang.IllegalArgumentException: Invalid parent record: com.glide.rest.util.RESTRuntimeException: java.lang.IllegalArgumentException: Invalid parent record"

Release or Environment

All Releases

Cause

The error message is as the system is not able to find the 'Parent' field in the form.

Network error message:

error: {message: "java.lang.IllegalArgumentException: Invalid parent record",…}
detail: "Invalid parent record Check logs for error trace or enable glide.rest.debug property to verify REST request processing"
message: "java.lang.IllegalArgumentException: Invalid parent record"

Resolution

1. Log in to the instance from Platform.

2. Open the record from the Mobile view.

3.Configure -> Form Layout.

4.Add the 'Parent' field to the Form layout.

Additional Information

Configuring the form layout:

https://docs.servicenow.com/bundle/quebec-platform-administration/page/administer/form-administration/concept/configure-form-layout.html