Sys_pop up view on request item field (sc_req_item.cat_item) does not work when clicking on preview (i) icon


Description

When clicking on the preview icon (i) on the "ITEM" field  (sc_req_item.cat_item) on the requested item table, custom sys_pop up view does not show.

 

Instead, the default view with service catalog item opens up

 

 

Release or Environment

Any supported releases

Cause

The attributes on the dictionary entry for the item field are causing the default view to be shown.

 

popup_processor=com.glideapp.servicecatalog.CatItemPopper,popover=true

 

Record:

https://<instance-name>/nav_to.do?uri=%2Fsys_dictionary.do%3Fsys_id%3Ddc31454f6d2620100acb70b3534330f8%26sysparm_view%3Dadvanced

Resolution

Removing the attributes on the dictionary record will allow the custom sys_pop up view to be displayed when clicking on the preview icon on the requested item field 

 

Open the record below:

https://<instance-name>/nav_to.do?uri=%2Fsys_dictionary.do%3Fsysparm_referring_url%3Dsc_req_item.do%253Fsys_id%253D6da393bb1b453c10f9d16579b04bcbae%254099%2540sysparm_record_target%253Dsc_req_item%26sysparm_view%3D%26sysparm_query%3Dname%253Dsc_req_item%255Eelement%253Dcat_item%26sysparm_query_encoded%3Dname%253Dsc_req_item%255Eelement%253Dcat_item

 

Click on advanced view

 

Remove the Attributes from the attributes field