LDAP via MID is failing after 55 S


Description

LDAP via MID server is failing and  getting below error screen

 

Cause

Check in the ECC queue and make sure you are getting proper Output and Input record for the LDAP test connection Probe. In this case, we could see there are no Input records being created for its corresponding Output

 

From the MID logs, you may see like

2021-06-28 13:40:28 (732) ECCSender.1 WARNING *** WARNING *** Method failed: (https://<instance>.service-now.com/ecc_queue.do?SOAP&displayvalue=all&redirectSupported=true)HTTP/1.1 500 Internal Server Error with code: 500
2021-06-28 13:40:28 (732) ECCSender.1 WARNING *** WARNING *** Unable to parse SOAP document
2021-06-28 13:40:28 (732) ECCSender.1 WARNING *** WARNING *** RemoteGlideRecord failed to send data to https://<instance>.service-now.com/ with (Unable to parse SOAP document)
2021-06-28 13:40:28 (732) ECCSender.1 WARNING *** WARNING *** MIDRemoteGlideRecord.insert failed, retrying in 113 seconds
2021-06-28 13:40:46 (516) Worker-Expedited:LDAPConnectionTesterProbe-8d1323451b09f410598063d76e4bcb64 Worker starting: LDAPConnectionTesterProbe source: b05ce812dbdc6f009af25e45dc9619b2
2021-06-28 13:40:46 (761) Worker-Expedited:LDAPConnectionTesterProbe-8d1323451b09f410598063d76e4bcb64 Enqueuing: D:\PPM PROD MID SERVER\mid.kingston-10-17-2017__patch6-05-16-2018_05-24-2018_1317.windows.x86-64\agent\work\monitors\ECCSender\output_s\ecc_queue.17a526bfd270000001.xml
2021-06-28 13:40:46 (764) Worker-Expedited:LDAPConnectionTesterProbe-8d1323451b09f410598063d76e4bcb64 Worker completed: LDAPConnectionTesterProbe source: b05ce812dbdc6f009af25e45dc9619b2 time: 0:00:00.242

 

So here the MID server is not able to communicate back to the instance

Resolution

After performing the below steps, MID server will be able to communicate with LDAP.


1. Stop the MID Server service
2. Take a backup of folders found in the <MID server installation path>/agent/work/monitors/ECCSender/ directory - Be sure to move the backed up directories/files outside of the <MID server installation path>
3. Removed the folders from the directory
4. Restart the MID Server service
5. Run LDAP test

 

Note: If the MID server still fails even after performing the above steps, please follow the workaround mentioned on the KB0954447