Field Changes are Not Appearing for Filtered Activity on Mobile App


Description

The Activity stream for a Mobile form is not displaying all the expected field changes. 

Release or Environment

All Mobile Releases

Cause

On Mobile the activity stream by default will display all the field changes which the user has access to and are added on the activities filtered setting.

The fields displayed can not be changed or customized from the mobile view. 

 

Resolution

Things to Check: 

  1. Verify the user has ACL Read rights to the form Fields. 
  2. Check that the table for the field on the the form is being audited.
  3. Check the field dictionary record has the 'No_audit = true' attribute. 

If all above steps are reviewed, then the issue may be due to the table specific Activities (filtered) configuration. 

Verify the expected fields are all added to the activities stream by checking and updating the 'glide.ui.table_name_activity.fields' system property. 

 

Additional Information

Additional links for reference: 

https://docs.servicenow.com/bundle/quebec-mobile/page/administer/tablet-mobile-ui/task/configure-activity-stream.html

https://docs.servicenow.com/bundle/quebec-platform-administration/page/administer/form-administration/concept/c_ActivityFormatter.html