Amazon Service Catalog Item cannot load variables- Unable to retrieve launch paths for product: access denied


Description

1. Impersonate as any user that doesn't access to Amazon Service Catalog
2. Open the Service Catalog Item on the service portal or from the platform(maintain items)

Expect: Catalog Item to load all variables

Actual: None of the variables were loaded. Error:

Unable to retrieve launch paths for product sysid: access denied
Unable to retrieve provisioning artifacts for product sysid: access denied

Release or Environment

Quebec Patch 1 Hotfix 1

Cause

The user was not assigned to the required group "order aws products" as per requirement:

The section "Configuring AWS Service Management Connector scoped application" talks about permission and the group needed to give to end-users.
Configuring ServiceNow

Resolution

Assign the user to the group "order aws products".

1.Go to the affected user recordĀ 
2.In the related list tab - Groups. Click Edit.
3.Find and add "order aws products" to the Group list . Press save.


Additional Information

Debug security did not detect any ACL failure as this is not role-related but rather user group-related.