Servicenow MID Server Landing page<!-- /*NS Branding Styles*/ --> .ns-kb-css-body-editor-container { p { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } span { font-size: 12pt; font-family: Lato; color: var(--now-color--text-primary, #000000); } h2 { font-size: 24pt; font-family: Lato; color: var(--now-color--text-primary, black); } h3 { font-size: 18pt; font-family: Lato; color: var(--now-color--text-primary, black); } h4 { font-size: 14pt; font-family: Lato; color: var(--now-color--text-primary, black); } a { font-size: 12pt; font-family: Lato; color: var(--now-color--link-primary, #00718F); } a:hover { font-size: 12pt; color: var(--now-color--link-primary, #024F69); } a:target { font-size: 12pt; color: var(--now-color--link-primary, #032D42); } a:visited { font-size: 12pt; color: var(--now-color--link-primary, #00718f); } ul { font-size: 12pt; font-family: Lato; } li { font-size: 12pt; font-family: Lato; } img { display: ; max-width: ; width: ; height: ; } } .mce-toc{background-color:#f7f7f7;padding:10px;border-radius:5px;border:1px solid #dedede;width:50%;min-width:500px;} Table of Contents OverviewRecent InclusionsMID Server ConfigurationMID Server InstallationMID Server UpgradesMID Server CertificatesMID Server Down & ConnectivityMID Server PropertiesMID Server Resource UtilizationMID Server with AntivirusMID Server ECC Queue & DiscoveryMID Server for Integrations Overview This article is a reference guide to the knowledge base articles and additional support resources that will help us to resolve the issues faster referring KB in this Article. MID Server Recent Inclusions TLS Security Policy for the MID ServerTruststore Migration for MID ServerDiscovery Command Audit Logs - "mid.log.command.audit.enable"Unified Keystore for MID Server MID Server Configuration Configuring MID Servers Knowledge Base Articles MID Server configured to use Edge Proxy fails to start if forward proxy is also configuredMID Servers and IP Address Access ControlSupported platform changes for MID ServerMID Servers and ClonesRole required to see the MID Server moduleMID Server Prerequisites - Connections to allow list for the MID ServerInstall Java 11 on MID serversHow to change MID Server userWhich features do MID Servers not support, depending on whether it is running on a Linux or Windows HostMID Server stops logging agent logs when an unsupported JDBC type data source is used.How to Update a MID Server passwordHow to verify the signatures and integrity of signed MID Server JAR filesShould MID Server wrapper.conf file be edited?Pros and cons of hosting multiple MID servers on the same single physical machine MID Server Installation Installing the MID Server Knowledge Base Articles Paris MID Server installation steps with screenshotsCreate a Windows service account with "Log on as Service"PolicyKit issues with Linux MID Servers using non-admin accountsNewly installed mid server is not showing upHow to move an existing MID Server installation between host serversWhich Java versions are supported and compatible with MID Servers (OpenJDK/Oracle JRE)Install Java 11 on MID serversMID Server download packages for installing OpenJDK on Windows and Linux hostsQuebec - MID Server Installation (With Mutual Authentication)Unable to see a new installed MID Server in services.msc or need to uninstall a MID ServerMID Server Service does not get Installed without proper privilegesMID Server download error "The requested URL was not found on this server"Running multiple MID server Services/Daemons on a single Linux Server is supported from Orlando onwardsAn error was discovered processing the WS-Security header during MID Server InstallationUnable to install the ServiceNow MID Server_XXXX - The filename, directory name, or volume label syntax is incorrect.MID Server ZIP installer issues when using XML Special Characters in the PasswordHow to make MID Server use a proxy for all trafficMID Server Installer (ZIP) log shows "access restricted" for instance details values, and fails to authenticate the userMID Server Installation does not create a record in the InstanceInstalling MID on Windows Server Core Known Errors With MSI Windows Installer for MID Server, the "Log on as Service" rights check can fail with users in Administrator group MID Server Upgrades MID Server upgrades Knowledge Base Articles MID Server connection failures when upgrading to Quebec MID Server Auto Upgrade hanging issuesMID Server upgrade process - What actually happens when a MID Server upgrades itself?MID server upgrade fails due to: [wmi_collector.exe cannot be deleted .... cannot access the file because it is being used by another process]MID Server fails to auto upgrade and to restart with agent log error "wrapper-windows-x86-64.exe cannot be deleted"How to manually restore a MID Server after a failed upgradeMID server auto-upgrade fails while copying files from temp to agent folder on Windows even with ''Application Experience' enabledHow to continue a MID Server upgrade after it has crashed in the middle of the ServiceNow Platform Distribution Upgrade service leaving the MID Server down and service not runningFinding which process has locked a file during a MID Server auto-upgrade using Windows Resource Monitor (resmon.exe)Post Upgrade Mid-Servers have errors related to MID Server encryption and decrypting file informationMid Server issue after clone and upgrade: "Unable to subscribe to AMB channel: /mid/server/Mid Server issue after clone and upgrade: "Unable to subscribe to AMB channel: /mid/server/"Unable to upgrade the midserver for Quebec, Unable to load key store, MID server will not able to functionMID Server version compatibilityHow to upgrade a MID Server that does not have access to the AutoUpgrade install server on the InternetMIDSERVER : SEVERE *** ERROR *** (34180)FileDBProviderImpl - Failed to clean the DB Cached files during MID startupTroubleshooting "[File] cannot be deleted" errors in Wrapper log when attempting to AutoUpgrade MID serverMID Server upgrade error "Platform Distribution Upgrade service is not installed"MID Server upgrade error "java.lang.IllegalStateException: Filesystem permissions are incorrect" in agent logsHow to stop the MID Server from auto upgradingMid server name having a special character "&" causing issues when Mid server upgradesTrouble shooting and collect information when MID Server goes Down after UpgradeControlling mid server version and mid server upgrades.MID Server Manual upgrade failing and corrupting the installation files Known Errors Issue with LDAPS Connection via MID since Quebec EA UpgradeThe fix for PRB1320637 requires that the cacerts Truststore file password remains as the default "changeit", which many customers won't allow, causing certificate deletion during JRE upgrades (e.g. Quebec) and subsequent MID Server and Integration outageA MID Server upgrade that includes a new JRE version will overwrite the cacerts file Linux MID server auto-upgrade can fail even on Tanuki wrapper version 3.5.36 if MID service is not reinstalledMID Server service starts regardless of whether a failed Upgrade Service still remains, leading to deletion of the upgrade service, and potentially leaving the MID Server running in a semi-upgraded and corrupt state MID Server down after attempted upgrade, due to file locks caused by Dell SecureWorks Red Cloak anti-virus (mid.bat, java.exe, wrapper-windows-x86-64.exe)The MID Server Upgrade service doesn't properly detect if the MID Server has fully shut down, and so has issues with file locks when it starts deleting, potentially leaving the MID Server downMID Server pre-upgrade check fails with PSReadLine/PSConsoleReadLine/WinIOError error In Quebec : MID Server upgrade stops if Powershell tests in Pre-upgradecheck failed and Powerconsole remains busy and the closing the session failed MID Server Certificates CertificatesMID Server certificate check policies Knowledge Base Articles MID Servers and CertificatesMID Server TLS/SSL certificate check policy Quebec upgrade informationHow to obtain SSL certificate from the browser MID Server upgrades could reset the Java properties and certificates installed on cacertsREST Message via MID Server - Unable to decrypt parameter: rest_password, causes 401 - Invalid username/password comboMID server OSCP requirement detailsMID Server cannot connect to ServiceNow instance, error in agent log: org.apache.commons.httpclient.HttpException: javax.net.ssl.SSLPeerUnverifiedException: peer not authenticatedLDAPS with MID server failed with Error "PKIX path building failed: java.security.cert.CertPathBuilderException"MID Server TLS policy for cloud, container, and external IPsMID Server certificate check security policies for self-hosted customersVerify all AWS certificates needed to establish a connection from the MID server to the AWS cloud server"No issuer certificate for certificate in certification path found" error observed on the MID logs MID Server certificate check security policies for self-hosted customersMID Server: No certificates identified for TrustStore migrationMID Server security property for self signed certificates is not honoured Known Errors MID Server shows certificate chain errors with self-signed certMID Server can fail to install or upgrade to Orlando due to new external connectivity requirement to ocsp.entrust.net for OCSP certification revocation verification check MID Server Down & Connectivity MID Server fails to startResolving MID Server issues Knowledge Base Articles MID Server Down troubleshootingMID Server - Shutdown failed: Timed out waiting for signal from JVMMID Server shows DOWN after starting up or restarting due to SOAP ErrorsMID Server Issue: "A MID Server with a duplicate name of sys_id was prevented from connecting. Install path C:\MID Server Issue: "A MID Server with a duplicate name of sys_id was prevented from connecting. Install path C:\. The issue must be manually resolved."MID server is down and in validating status. Timed out waiting for the OS to forcibly terminate the JVM processUsing MID Server with Microsoft Forefront Threat Management Gateway (TMG)MID Server Down and Error about Disk spaceMID Server won't start due to Root Certificate requirements - wrapper error "The digital signature of the object did not verify"com.snc.glide.amb.AMBClient$ProxyBuilderException: java.net.URISyntaxException: Expected closing bracket for IPv6 address at index 13WMI Collector deprecation detailsMID Server: troubleshooting WMI/Powershell issues - CredentialsMID Server Issue PowershellIntializationMID Server PowerShell Initialization Issue with error message [Error encountered when invoking PowerShell, the result from running '"C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe" -noninteractive -nologo -noprofile ...]Troubleshooting MID Server connectivity with the instanceError: "Could not decrypt file discovery whitelist after sync"Cannot connect, status is SSH_CONNECTION_FAILURE. Could not agree on key exchange algorithmMID Servers stuck in validating stateMid server Down - Error "Timed out waiting for wrapperServiceMain" seen in wrapper logMid server startup failed with error 1053: The Service did not Respond to the Start or Control RequestHow to change the TEMP folder used for MID ServerRequired list of IP address for ocsp.entrust.net for firewall team to whitelist the oscp.entrust.net endpoint for mid server communicationUnable to find two services for two mid serversNew MID Server service on linux fails to start if another MID server is already installed on the same hostMid Server issue after clone and upgrade: "Unable to subscribe to AMB channel: /mid/server/Mid Server issue after clone and upgrade: "Unable to subscribe to AMB channel: /mid/server/"Mid Server restarts frequentlyOrlando MID Error: "An unexpected error occurred: Permission denied Move-Item : Access to the path is denied."MID Server Credential test failingLinux MID Server startup error failed to resolve the version of JavaMid server having special characters in name will cause issues ensure proper formatting for the MID ServerMID server error "Error 2 'System cannot find the file specified'"MID error: Field(s) present in the query do not have permission to be read com.glide.processors.soap.SOAPProcessingException: Field(s) present in the query do not have permission to be readMid Server Connectivity/Validation Issues in ParisUP time Report on Service Now Instance and Mid ServerHTTP 500 Response and 'Unable to parse SOAP document' Causes MID Server Issues from Past Failed SOAP ParsingMID Server: "Validate" UI action doesn't do anythingMid Server records on instance responding VERY Slowly to UP and DOWN state of Mid Server Service, VALIDATION not completing[MID with Proxy] MID Server service might be started but its still shown as DOWN in instanceMID Server error: An unexpected error occurred: The term 'XXX' is not recognized as the name of a cmdlet, function, script file, or operable programWindows Could not start MID Server ServiceFailed transfer plan context to new MID because all MIDs capable of running plan are downMID Server Down on Scheduled Export Set Jobsmid_server.down events are generated even if the mid server is not actually downMid server running but displaying the error "MID Server not operational (status: Down), possibly due to recent clone." Known Errors File permissions enforcement removes permissions of the windows service's log on as user, when computer or domain name has lowercase letters, leaving MID Server downMid Server DOWN due to false "expected service name" error, (1) if because of powershell issue the service name cannot be fetched or (2) if the 'case' of the Service Name not exactly matching between wrapper-override.conf and the running service/registryMID Server throws fatal error EXCEPTION_ACCESS_VIOLATION and goes Down when using Java 8 Update 261 (JRE 1.8.0_261) MID Server status in instance changes to DOWN after BR "Discovery - Update device started count" attempts to run multiple times. MID Server Properties MID Server propertiesMID Server parameters Knowledge Base Articles Controlling mid server version and mid server upgradesEnable SSH Debug on a MID server MID Server Resource Utilization MID Server reference information Knowledge Base Articles Request body exceeded max allowed content lengthMID Server high CPU consumptionResolving "Unable to kill PowerShell" errors in Windows MID ServersMID Server Performance ReportsMID Server CPU running at 100% since upgrade to Orlando and High Memory Usage on Mid Servers during DiscoveryHigh CPU Usage on Host with MID Server(s)Discovery MID Servers at 100% CPU - Good or Bad, Why and then what?Mid server service restarts frequently due to "mdmp" files accumulating the MID installation folderHow to collect the Thread dump for all MID servers via a script? MID Server wrapper logs contain INFO message "Wrapper Process has not received any CPU time. Extending timeouts."Stuck PowerShell processes on the MID server host Mid Server Import IssueHow to remotely monitor per-process CPU and Memory usage of a MID Server hostHuge ssh.log file on MID ServerIntercepting MID server traffic to an instance Known Errors MID server can fail to start, throwing an Out-of-Memory error, if there are a large number of XML files in the ECC Sender folderThe default/recommended MID Server CPU alert/mid server issue threshold is unrealistic for a MID Server doing DiscoveryConcurrency performance: JVM locks on OCSPCheckedCertificateCache are not released leading to import schedules taking exponentially longer (WARNING *** Freed stuck JVM lock: OCSPCheckedCertificateCache) MID Server with Antivirus Knowledge Base Articles How to add Exclusion set for the MID Server in Cisco AMP to prevent MID Server upgrade failAllow Powershell scripts to pass through antivirusSome Anti-viruses are blocking MID Server Upgrade Known Errors Upgrade fails leaving MID Server DOWN, due to antivirus/security software flagging InjectorService.exe as Malware/TrojanMID Server down after attempted upgrade, due to file locks caused by Dell SecureWorks Red Cloak anti-virus (mid.bat, java.exe, wrapper-windows-x86-64.exe)MID Server upgrade fails leaving MID Server Down, due to Cisco AMP antivirus preventing the upgrade service deleting the Wrapper executableMID Server Upgrade fails if the temp directory of the JVM is changed to a path including spaces (to try to avoid antivirus/security blocking temp folder during upgrade) MID Server ECC Queue & Discovery MID Server ECC Queue Knowledge Base Articles Windows discovery using WMI fails with - Error evaling C:\Users\dnsadmin\AppData\Local\Temp\GenerateWMIScriptJS_WMI_FetchData6214298325369083622.js: Expected ';'Troubleshooting ECC Queue performance by inspecting the ECC Queue input recordsHow the ECC Queue works - from output ready, to input processedWhy are my MID Server-related Jobs stuck and ECC Queue inputs still in Ready State?In Paris release, Windows - Classify probe fails if credential username is in "user@domain" format instead of "domain\user", error is: New-CimSession : Access is deniedSSH authentication failing post Quebec upgradeHow are the Agent Client Collector record fields populated, and why might the CI field be empty?The MID Server WinRMAPI PowerShell Module update to the PSModulePath system variable is failingSSH Privileged CommandsSpecific MID server throws credential related issue if picked up for Service Mapping from MID ClusterHow to link an ECC Queue record back to a specific Feature or JobDiscovery Log Error on HTTP Classify Sensor "Sensor error when processing HTTP - Classify: -----------------------------Stack:com.snc.mid.util.midselector.MidServersConfig.getMidServerByDisplayName"MID Server is not processing JDBCProbe requests / ECC Records.Unable to Find a Proper MID Server when Discovering a Host with Quick DiscoveryHow MID Server File Synchronisation works, to help when TroubleshootingMID Server doesn't process python codejava.nio.BufferOverflowException with syslog probe transactions on midserverMID Server Max Threads, Worker Groups , Priority and QueuesHow to disable messages "No mid found to trigger credential-less discovery for <How to disable messages "No mid found to trigger credential-less discovery for <>" in discovery logs'ActionTest' action in Flow Designer is in 'in progress' state for a very long time (days) intermittently.SEVERE *** ERROR *** Unknown credential type downloaded; MID server may not have access to credentials table Known Errors Windows discovery classifier ends up with "The term 'executeWindowsClassify' is not recognized as the name of a cmdlet"[Paris upgrade]: WMI: Classify can fail, if "target_powershell_access" is false MID Server for Integrations Knowledge Base Articles Script include that calls JDBCProbe fails with java.lang.NullPointerExceptionWhen trying to connect MID Server to SCCM data sources, getting error as "Did not get a response from the MID server"Why do my integrations via MID Servers sometimes take up to 40 seconds longer to run, or timeout?MID Server Selection for Service Graph Connector for SolarWindsJDBC Data Source execution fails with "Did not get a response from the MID server"Data Source Test Load 20 Records Fails with Did Not Get a Response From the MID Server errorFlow Designer MID Server Action StepMID Server Cluster for ITOM Event Management Connector InstancesCyberark integration fails with unauthorized errorsWhy do my integrations via MID Servers sometimes take up to 40 seconds longer to run, or timeout?IntegrationHub: Unable to resolve IP Address for the host name: xyz.domain.com at com.snc.mid.util.midselector.IPRangeMidFilter:242CyberArk credential storage can not authenticate when the CyberArk credential identifier is <Blank>MID Server startup fails after configuring CyberARk parameter mid.secure_config.providerLink to Source Control over MID server: Operation encountered an unexpected error due to the 'bundle' file extension missing from glide.attachment.extensions when configured.Test SAP Connections and Versions failing with an "Couldn't find a valid mid server"Runtime NULL exception thrown for testing external store credentials.MID server not able to connect when configured with a user with LDAP AuthenticationHow to link application to source control via MID serverExport set "Scheduled Data Exports" intermittent 'Completed with errors' Known Errors LDAP "Test Connection" and "Browse" features can timeout, and LDAP Monitor may show Connection Status as Not Connected, due to running at Standard(2) MID Server priority - Did not get a response from the MID server after waiting for 55 secondsPowershell MID Server Script Files used by Orchestration Activity Packs are not signed, which is a requirement for some customersMID server running Oracle JRE version 8 release 231 can't start some applications - Discovery Powershell/WMI probes fail, Event Management SCOM connector won't start