SSO not working as expected after upgrade from Orlando release


Description

Before upgrading to any release post-Orlando, the SSO is working fine.

But after the upgrade to Paris/Quebec version, the SSO is not working as expected on that same instance.


Release or Environment

All releases before and including Orlando.

Cause

Before the release of 'Paris', we were using 3 different plugins for enabling Single Sign-On on the instance. See the screenshot)

This feature was updated in releases post-Orlando release (Paris, Quebec, etc.) where we are now using one streamlined plugin for enabling SSO ie. 'Integration - Multiple Provider Single Sign-On Installer'

Also, the SSO configuration options were updated for enabling SSO and configuring SSO and other options in the Filter Navigator.




Resolution

After you update the instance to Paris release and later, to activate SSO again please do the following :

  1. Install the plugin 'Integration - Multiple Provider Single Sign-On Installer'
  2. Then enable the checkbox for multi-provider SSO property 'glide.authenticate.multisso.enabled' which can be found in the Filter Navigator 'Multiple Provider SSO>Properties'



Additional Information

SSO should be working fine now after following the above steps and for additional setup please follow the below ServiceNow documentation: