MIDSERVER : SEVERE *** ERROR *** (34180)FileDBProviderImpl - Failed to clean the DB Cached files during MID startup


Description

The Midserver has failed the auto-upgrade with below error

SEVERE *** ERROR *** (34180)FileDBProviderImpl - Failed to clean the DB Cached files during MID startup

Cause

Mid server service account is not able to delete the files from agent/work/hr directory because of permission issue

Resolution

 
Mid server logs shows below error in the logs 
12/19/20 00:53:28 (393) Wrapper-Stopper SEVERE *** ERROR *** (34180)FileDBProviderImpl - Failed to clean the DB Cached files during MID startup
12/19/20 00:53:28 (393) Wrapper-Stopper interrupting thread IdleConnectionMonitor.5
This error is thrown when it's trying to delete files from agent\work\h2 and fails

So looks like user account which is used to run your mid server service does not have full admin rights on the agent folder . So it is not able to deleted filed from agent\work\hr directory.
So to resolve this issue please check permissions of mid server service user account and ensure it has full admin rights on the agent folder.