After upgrading to Paris, Email importance defaults to low when created from Agent Workspace


Description

When emails are generated from Agent Workspace, the default behaviour is to set the Importance of the email to "Low".

Release or Environment

Paris and onwards.

Cause

An Importance flag was introduced to the Email Client in Agent Workspace. By default the flag is unset which means the Importance is "Low", however if it is checked then the Importance is set to "High".

Resolution

To modify the behaviour of emails created from Agent Workspace defaulting the Importance to "Low", you can implement a Business Rule on the [sys_email] table similar to the one below.