Software Asset Reconciliation jobs failing post upgrade to Paris


Description

Software Asset Reconciliation jobs failing post upgrade to Paris. An error message like the following can be seen from the system logs whenever the "Reconciliation" fails:

{
"message": "Failure to insert object",
"table": "cmdb_software_product_model",
"lastGlideError": "Operation against file 'cmdb_software_product_model' was aborted by Business Rule 'Product should match publisher^d180d0a21b4d2050f80af5f61a4bcb28'. Business Rule Stack:Product should match publisher",
"changes": {
"manufacturer": "77647f0d1b67c8d06086844fdd4bcb4b",
"product": "7a0267d3dbf81810c41a10825b9619d2",
"version": "",
"version_operator": "is_anything",
"language": "832bec5493212200caef14f1b47ffb56",
"language_operator": "is_anything",
"platform": "anything",
"platform_operator": "is_anything",
"edition": "",
"edition_operator": "is_anything",
"created_source": "system_property"
}

Release or Environment

Paris

Cause

This issue is seen when there are multiple records of Core Company with "Normalized= true". Ideally at any given point of time, there will be a single normalized core company. In general, there would be a time lag of 1 week for the cds_client_mapping (Content data) to be pulled to an instance. Prior to this pull, if core company is not resolved for any record, then we create one with "Normalized = true". Later when the client mapping is pulled, there will be another Core company with Normalized = true and that how this issue is seen.

Resolution

Note: Any testing should first be done in a non-production instance

This issue is fixed on Quebec so that CDS client mapping data is downloaded on SAM plugin activation.

To fix the current data, follow the instruction on KB0961268 Issues with invalid Publisher and Manufacturer in Software Asset Management Professional