Unable to add "Recommended Fields" Under Completeness for "Business Applications " Table


Description

Unable to add "Recommended Fields" Under Completeness for "Business Applications " Table

Release or Environment

Paris

Cause

As per OOTB I could not add "Recommended Fields," to 'Global' scope or APM Scope. Refer to the screenshot.

The below documentation implies with reference to the 'Global' scope and does not specify in the documentation that the 'SCOPE' has to be selected/changed.
https://docs.servicenow.com/bundle/madrid-servicenow-platform/page/product/configuration-management/task/t_MakingAFieldRecommended.html

The collection record scope was changed in a previous case
Therefore creating an issue saving the recommended fields as they were in a different scope
OOB it does not matter if you are in global scope or APM scope as long as the collection is in the same scope
i.e. if the collection record and cmdb_recommended_fields > Business Application record are in different scope breaking the selection.
If the scope is different you cannot select the records because the table is not visible.

Resolution

Fix applied setting attribute allow_public=true

- see documentation: https://docs.servicenow.com/bundle/paris-platform-administration/page/administer/reference-pages/concept/c_DictionaryAttributes.html

https://empswarnockp.service-now.com/nav_to.do?uri=sys_dictionary.do?sys_id=5be79eca1b131010aa45b888cc4bcb06

Confirmed that this fixes the issue.



Additional Information

Steps to reproduce

Browse to Filter Navigator => CI Class Manager => Search for Business Application => Click on Health -> Completeness => Click Recommended Fields => Move or select any field and click on Save.