Issue with retrieval of the remote update sets. Getting a message 'Job is not in the queue yet'


Description

When attempting to retrieve or preview the Update Sets , users gets the following message on the progress bar

"Job is not in the queue yet"

Cause

1. User attempting to Retrieve/Preview update set would require insert/update access to the table sys_trigger , In some cases if this is customised on the instance and the admin users are restricted access to the table sys_trigger , this will have to be reviewed by the customer.

Or

2. The node on which the attempt is made to Retrieve/Preview  may not be able to process the jobs assigned to it and will have to be reviewed by ServiceNow support.

Resolution

1. Review if there is any customization around sys_trigger table

2. Raise a case with ServiceNow support to determine the cause of the issue if it is specific to node.