KB article URL is not showing Login prompt for SSO users


Description

An internal KB article URL for non logged in user is not taking to the SSO login page, instead, it's throwing the error from a portal page "Article not found".

Cause

If you are using a portal page to view KB articles, please check the below Pages are Public or not

If those pages are enabled as public, revert it by unchecking the Public buttons


https://<INSTANCE>.service-now.com/nav_to.do?uri=sp_page.do?sys_id=dea5792147132100ba13a5554ee4902d



Resolution

Disabling the Public of Portal page will take to the login page, either SSO or Local logins.