Push notification not working for a specific user


Description

When creating a new push notification and and generate the required event it should trigger  the push notification but does not generate errors nor notification

The cmn_notif_device table is set up properly for the corresponding user as stated on KB0855301

Release or Environment

All

Cause

Although the notification works when we change it to email type and the cmn_notif_device and the user is subscribed to the notification, The sys_push_notif_app_install for the user is inactive  or has another app in the application record.

Resolution

Validate the sys_push_notif_app_install table for the users you expect receive the notification, the active field has to be enabled. Additionally, if there is no record of a user you can create it.

Always make sure that the push message added refers to right application (for example  "ServiceNow Classic Mobile Application") in the sys_push_notif_app_install table for affected user