Technical Services: View Result - "No records to display"


Description

Clicking the "View Result" UI Action from the Technical Service record and encountered "No records to display".

Note:

a. Create technical services in one of the Instance A.
b. Export the records from Instance A and import it to Instance B.

Steps to reproduce:

1. Login to <Instance B>.
2. Navigate to "Service Mapping > Services > Technical Services"
3. Open a record
4. Click "Preview", shows <##> records.
5. Click "View Result", "No records to display"

Release or Environment

All

Cause

It seems that the hash field for the technical service showed the correct number although the svc_ci_assoc table was not filled with CIs.

It can happen for example when the service record is copied from another instance (without coping the svc_ci_assoc table).


Resolution

1. Clear the "Hash" values of all the Technical Services [cmdb_ci_query_based_service].

2. Run [Execute Now] the Scheduled Job [Update Query Based Services] to calculates the Technical Services.