Appointment Booking calendar cannot override or set default date on picker based on lead time


Description

User cannot set a default date to show in the date picker widget for appointment booking.

The date is always defaulted to today's date or week event though the lead time was set to more than one week

The lead time can be set in sn_apptmnt_booking_service_config


Cause

This is the expected behaviour

The available bookable windows is [today + Lead time, today + Future bookable max days], but the calendar will always display current week's slots when it's first opened

Resolution

You can create a custom widget or raise an Idea in the Idea Management Portal for enhancement of this functionality 

To raise an Idea, please see:

https://support.servicenow.com/kb_view.do?sysparm_article=KB0547257