Service Portal - Create Case - Contextual search widget not working in related content


Description

External user do not see the content of the knowledge article when selecting one in the related content section (Contextual Search widget within the create case catalog item, see attached screenshot)

Note: External users can see the knowledge in the backend without any problems

Release or Environment

All

Cause

This is due to ACLs, the widget render the article in different section (description, short description, article body, etc.) and ACLs set on these fields can block the external users to see the content of the article.

Resolution

Ensure the read ACLs on kb_knowledge fields are set correctly (kb_knowledge.short_description, .article_body, etc.)