"Company inactive - your access to this instance is not authorized" error when trying to login on domain separated instance


Description

Users cannot login (local authentication) on domain separated instance. Error is thrown: "Company inactive - your access to this instance is not authorized", even though company record is active.

Cause

OOTB Guest user not in the global domain.

The error comes from OOTB Script Include "CompanyActiveUserAuthenticationGate", as Guest doesn't have visibility on the domain of the users logging in.

Resolution

Ensure the Guest user is active and in the global domain. As Guest is used in many different parts of the platform, moving the user to a different domain can cause unexpected errors.

Notes:

Additional Information