After upgrade to New York, Service Portal - Knowledge search word does not display in bold


Description

The results returned from the typeahead search are not bold. Type "Apple" into the "How can we help?" search box on the main portal page. Expected behavior is that the results should return bold while the actual behavior is that the results returned are not bold.

Cause

The issue is due to an intentional change in the angular ng-template.

sp-typeahead.html - https://<instance-name>.service-now.com/nav_to.do?uri=sp_ng_template.do?sys_id=c4d2d1765b8212000d7ec7ad31f91acc

The line number 4 has changed from Madrid to New York as shown below.
Madrid
<span ng-bind-html="match.label | uibTypeaheadHighlight:query"></span>

New York
<span ng-bind-html="match.label | uibTypeaheadHighlight:match.model.query"></span>

Resolution

Updating the line number 4 in the Angular ng-template will fix the issue.