Recipient list on survey Dynamic creation issue


Description

Customer is experiencing an issue with Recipient list on survey Dynamic creation issue

When you try to create on reception list a dynamic list based on filter , but even if you change the filter nothing appear on the related list recipients.
It works like expected when you do a manual import.

 

Steps to Reproduce:

Navigate to Survey Administration > Recipient List 
Create a dynamic list based on filter

select values in the field below

Table: sys_user

User Field:Email

Condition:Email contains <value>


Click on refresh recipient list

 

Current: The recipient related list is not populated.

Expected: The recipient related list is populated with Users who meet the condition defined.

Cause


THE 'User Field' value is not defined correctly.

I could reproduce the issue OOB with the same definitions customer had.

However after I have modified the 'User Field' and selected the 'sys_id', this functions correctly.

 

Resolution


Change the 'User Field' value to sys_id.




Additional Information

You can also refer to the documentation below:


https://docs.servicenow.com/csh?topicname=t_TargetCommCreateRecipientList.html&version=latest