New York Upgrade issue : Change Request 'Routine' view is not deleted


Description

As per the ServiceNow documentation Change Management Release Notes "Removed in this release" section, the Routine form view of [change_request] is removed. "The files related to this view are deleted from the sys_ui_view.list."

You may notice after an instance is upgraded to NY that Change Request->Routine view still exists.

Release or Environment

New York

Cause

It is expected that only z-boot or new N-family provisioned instances will not have the Routine view.  The documentation may be causing some confusion.  There is a documentation request to clarify per this note from ServiceNow Development: 

"The Routine view will not be removed for upgrading customers, only for Zboot customers starting from New York the Routine view should not be present."

Resolution

This is the expected behavior for upgraded instances.