Limit for comments posted by a user on KB articles - New York


Description

In a New York environment when a user comments or rates a KB article an error message appears: "You have reached the daily limit for comments posted by a user." 

Cause

Basically the property glide.knowman.show_user_feedback.roles is set to knowledge_admin role and the users trying to post comments on article or submit rating on article do not have knowledge_admin roles.

OOB this property was not specified to any particular role.
glide.knowman.show_user_feedback.roles is blank.

Resolution

  1. Please set the correct roles in the property .
  2. Keep the property blank or probably do the setup correctly with the needed roles to post the comments based on the property.