Submitting a catalog item is stuck at 'Submitting' for the user and the request is never created


Description

Symptoms

When a user tries to submit any request from Service Portal, the page stucks in 'Submitting' and the request is never created.

Release

Any supported release

Cause

User has snc_read_only role.

Resolution

Removing the snc_read_only role fixes the issue 

Additional Information

Link to documentation on snc_read_only role :

https://docs.servicenow.com/csh?topicname=c_ReadOnlyRole.html&version=latest