Initial Communication template does not populate email in Incident workbench


Description

Symptoms


Emails are not populated with email contacts when using Initial Communication (Technical) email client template.

Cause


No Contacts definition corresponding to Incident communication plan.

Resolution


The behavior is due to there not being a defined Contacts definition. In the script include MIMWorkbenchUtil, the getEmailAddresses function (which is called from the Initial Communication (Technical) email client template) is searching for a Contacts definition to pull the email information from. Since this had not been created, the information was not populating in the workbench. Please see the documentation below for creating a Contact definition.

Additional Information


Create a contact definition 
https://docs.servicenow.com/csh?topicname=t_CreateAContactDefinition.html&version=latest