Solution for Virtual Agent (VA) keyword being a stop word does not work for topics and throws "Your text query contained only common words or ambiguous wildcards, please refine your search and try again" error


Description

Symptoms

Virtual agent topic has a keyword that is a stop word in ts_stop table and using it triggers the following error on the platform:

"Your text query contained only common words or ambiguous wildcards, please refine your search and try again" error

Release

ALL

Cause

If the keyword is a stop word in ts_stop table, the topic wont show up as VA does a contextual search similar to global search and does not query stop words. 

Resolution

Create a new record in ts_index_stop for that word in the sys_metadata and mark it as 'Not a stop word'.

For example:

If the keyword for a topic is issue, go to ts_index_stop and create the following record:

Index: sys_metadata

Word: issue

Stop mode: Not a stop word