ServicePortal - Getting Failing Widget: Ticket Conversations error and exception


Description

Symptoms

When clicking a link from an email notification for a completed request the Ticket Conversation page for the Request fails with error: Failing Widget: Ticket Conversations error and exception

Release

All

Cause

The link being generated by the email notification may not be correct.

Resolution

Access the REQ Ticket conversation page from the service portal and compare the URL to the URL being generated by the link. In this case the URL being generated by the Email Notification was trying to access the correct record (sys_id) but the wrong table. 

Change the table referenced in the Email Notification script to the correct table from the record.

Additional Information

https://docs.servicenow.com/csh?topicname=t_CreateANotification.html&version=latest