Link to CSM portal cases shows the portal login page instead of redirecting to SSO login


Description

Symptoms

When you have Single Sign-on setup and you have an IdP set up as Auto-Redirect IdP, if a user is not already logged in to the instance and he/she accesses a link to a case in the 'csm' portal, they're presented with the portal login page instead of being redirected to the SSO Login page. 

Example link:

https://<instance-name>.service-now.com/csm?id=csm_ticket&table=sn_customerservice_case&sys_id=cfed727fdb447b007de090c7db9619ce&view=csp

Release

Applicable to all releases

Environment

This 'csm' portal comes as part of the plugin 'Customer Service Portal'.

Cause

In the CSM portal provided along with the 'Customer Service Portal' plugin, the login page is not specified in the "Login Page" field. This causes the user to be presented with the default portal login page which uses the public Login widget. This is configured by default to not redirect to the SSO login page.

Resolution

  1. Go to sp_portal.list 
  2. Select the portal named "Customer Support". 
  3. In the "Login Page" reference field, click on the lookup icon. 
  4. Select the page named 'csm_login' 
  5. Save the record. 

After implementing this solution, when a customer accesses the link, he/she will be presented with the CSM login page for a brief second before being redirected to SSO login.