Automated Test Framework test step Open a New Form on table sn_customerservice_case failure u_account does not exsist opening in service portal view


Description

Symptoms

ATF test step "Open a New Form" on table sn_customerservice_case returns failure with summary "This step failed because u_account does not exsist on form

Release

All

Cause

Service Portal view is brought up impersonating user that does not have the role "sn_customerservice_agent"

View Rule defines what view you are testing in based on your role:Resolution


Resolution

View Rule:

Case View for Customer Contact(browser)

1.) Add role of "sn_customerservice_agent" to your tester
2.) Add the table "sn_customerservice_case"

3.)Add view "case" (all lower case to match the view name) in the variable section of the test step open a new form

(See attachment)