"Link to Knowledge" related link UI Action on published Managed Documents form redirects the form to a previous page without creating the article.


Description

"Link to Knowledge" related link UI Action on published Managed Documents form redirects the form to a previous page without creating the article.

Cause

Type [knowledge_type] field is not added on the Document [dms_document] form

Resolution

  1. Go to Document [dms_document] form: https://<instance_name>.service-now.com/nav_to.do?uri=%2Fdms_document.do
  2. Click on the Context Menu OR right click on the header 
  3. Select Configure > Form Layout 
  4. Select "Knowledge Settings" Section if available
  5. Select "Type(knowledge_type)" to be available in the form 
  6. Save

Additional Information

Type specifies the type of knowledge article. Use Knowledge or any option that extends the kb_knowledge table. Note that when a knowledge article is created, the Type field becomes read-only.