When changing the "assigned_to" field on a record, user name is being set to "null", which changes the user name on sys_user table to null


Description

Symptoms


When changing the "assigned_to" field on a record, user name is being set to "null", which changes the user name on sys_user table to null

Release


All releases

Cause


Same user name is being populated more than once

Resolution


As stated in the following DOC:
Warning: It is not recommended to add the same field to more than one section of a form unless the field displays read-only data. Having two or more instances of an editable field can cause data loss and prevent the proper functioning of UI and data policies

Additional Information


https://docs.servicenow.com/csh?topicname=basic-form-administration.html&version=latest