The Fulfillment tasks created doesn't have 'Opened By' field filled out.


Description

The Fulfillment tasks created don’t have the’Opened By' field filled out. The field is blank.

 

Release or Environment

All releases.

Cause

The issue resides in Generic Service Request using "Approval Type" as "Workflow". So when the request is generated, it goes into approval type as workflow (based on SR config) and thus triggering global_SRA_GSR_approval workflow.


Resolution

Changing the "Approval Type" from "Workflow" to "None", the global_SRA_GSR_approval workflow does not get associated with the request which results in opened_by field to be populated from the RITM info.

Result:

Opened by field is filled successfully.