Anonymous users are getting an error message "You are unable to view this content due to security constraints" when using the live chat from service portal


Description

When an anonymous user in Service Portal and getting the following error messages "You are unable to view this content due to security constraints" while using an exact case number for the field "Case No. (If you have an existing case number to reference, please enter it here.)"

Cause

ACL restriction; the reason you are facing this issue is that the case table is not public.

Resolution

To resolve the error message please add the following ACLs:

  1. Table level Read access

    Type: Record
    Operation: Read
    Active: True
    Name: "case[sn_customerservice_case],None"
    Role: PublicĀ 

  2. Field level Read access

    Type: Record
    Operation: Read
    Active: True
    Name: "case[sn_customerservice_case],*"
    Role: PublicĀ 

Additional Information

ACL rule types